SWAM
Channels BIG issue

Hello! I'm using SWAM strings with Seaboard Rise 49 in Cubase Pro 10.
I want to play with several instances of SWAM strings simulatenously (to play polyphonic chords, each note on separate instance of SWAM - ensemble playing)
Ok, let's say, I created 4 instrumental tracks with SWAM instrument on each, end set midi options of each track to receive data from single channels (from 1 to 4). In Roli's Dashboard I selected "Multi Channel mode" with 1-4 channel range. But when I'm trying to play, all instances receives ALL channels.
I have "Trombone V3", and when I load 4 patches of it in NI Kontakt on separate midi channels - all works well - I can play polyphonic chords with separate pitchbend and expression for individual instance of trombone.
Please help.

Hello! I'm using SWAM strings with Seaboard Rise 49 in Cubase Pro 10. I want to play with several instances of SWAM strings simulatenously (to play polyphonic chords, each note on separate instance of SWAM - ensemble playing) Ok, let's say, I created 4 instrumental tracks with SWAM instrument on each, end set midi options of each track to receive data from single channels (from 1 to 4). In Roli's Dashboard I selected "Multi Channel mode" with 1-4 channel range. But when I'm trying to play, all instances receives ALL channels. I have "Trombone V3", and when I load 4 patches of it in NI Kontakt on separate midi channels - all works well - I can play polyphonic chords with separate pitchbend and expression for individual instance of trombone. Please help.

Did you set the Midi channel in Options -> Midi Mapping -> K.S. Midi Chan ?

-Michael

Did you set the Midi channel in Options -> Midi Mapping -> K.S. Midi Chan ? -Michael

The problem is solved by using the Input Transformer feature in Cubase 10 and the Channel Filtration feature in it. You can assign which channel can pass for each instance of the plugin. It is working!

The problem is solved by using the Input Transformer feature in Cubase 10 and the Channel Filtration feature in it. You can assign which channel can pass for each instance of the plugin. It is working!

Great that it works. But Nonetheless the Channel setting in the SWAM GUI should do the same thing.

-Michael

Great that it works. But Nonetheless the Channel setting in the SWAM GUI should do the same thing. -Michael

Mschnell, it seems it's Cubase 10 bug, maybe in older versions it works

Mschnell, it seems it's Cubase 10 bug, maybe in older versions it works

@mschnell Options -> Midi Mapping -> K.S. Midi Chan is for mapping the Key Switches on a different MIDI Channel, it's not the global receive channel.

With the Seaboard this is fundamental if you want to use a dedicated controller for the Key Switches: set it to MIDI CH 1. The additional controller must be set on MIDI CH 1 as well.

@YarKirGen, as you said, it seems a Cubase 10 bug. We will check it carefully, and eventually report to Steinberg.

Best!

@mschnell Options -> Midi Mapping -> K.S. Midi Chan is for mapping the **Key Switches** on a different MIDI Channel, it's not the global receive channel. With the Seaboard this is fundamental if you want to use a dedicated controller for the Key Switches: set it to MIDI CH 1. The additional controller must be set on MIDI CH 1 as well. @YarKirGen, as you said, it seems a Cubase 10 bug. We will check it carefully, and eventually report to Steinberg. Best!
edited Dec 11 '18 at 2:11 pm
92
6
4
live preview
enter atleast 1 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft